WordPress 5.0 version beta 1

WordPress 5.0 est disponible en version beta.

Cette version du CMS est une version de développement, il n’est donc pas conseillé de la mettre en place sur un site en ligne. Vous pouvez l’essayer sur une version de test de votre site.

Il y a deux façon d’essayer WordPress 5.0 en version beta : utiliser l’extension WordPress Beta Tester (activer le mode « bleeding edge nightlies ») ou télécharger et installer le ZIP de la version beta (lien de téléchargement direct).

La version finale de WordPress 5.0 est prévue pour le 19 novembre. D’ici là, nous allons passer en revue les changements principaux à tester sur cette future version majeure du CMS.

L’éditeur de blocs

Le nouvel éditeur de blocs Gutenberg est maintenant l’éditeur par défaut.

Il propose une expérience éditoriale moderne et enrichie mais aussi des API destinées aux développeurs et développeuses (consulter le guide de développement, en anglais).

Avant même d’installer WordPress 5.0, vous pouvez essayer la démonstration de l’éditeur de blocs.

Que faire si mon site n’est pas compatible ?

Bien entendu, il est possible que votre site ne soit pas prêt à utiliser ce nouvel éditeur, ou que vous utilisiez un constructeur de pages, un thème ou des extensions incompatibles avec le nouvel éditeur. Dans ce cas, vous pouvez installer l’extension Classic Editor dès aujourd’hui.

Si cette extension est en place sur votre site, vous pourrez mettre à jour vers WordPress 5.0 sans souci : l’ancien éditeur prendra alors la main sur le nouvel éditeur et votre site restera comme avant.

Le nouveau thème par défaut : Twenty Nineteen

En plus du nouvel éditeur de blocs, un nouveau thème par défaut est fourni. Nommé Twenty Nineteen, il a été conçu pour utiliser au maximum toutes les possibilités du nouvel éditeur.

Vous pourrez en savoir plus en lisant cet article d’introduction (en anglais) et suivre son développement et remonter des anomalies sur son dépôt Github (en anglais).

Aperçu d’un article sur le nouveau thème Twenty Nineteen
Édition d’un article en back-office avec Twenty Nineteen et le nouvel éditeur

Les autres thèmes par défaut

Tous les autres thèmes par défaut ont fait l’objet d’adaptations afin d’être pleinement compatibles avec le nouvel éditeur. Si vous utilisez l’un d’entre eux, vous pourrez donc profiter du nouvel éditeur.

La traduction en français de WordPress 5.0, du nouvel éditeur et du nouveau thème Twenty Nineteen

La traduction de WordPress et de son écosystème est assurée par l’équipe de traduction de WordPress en français. Si vous rencontrez des erreurs et souhaitez les remonter ou proposer des modifications, n’hésitez pas à publier des commentaires et des demandes sur le site dédié : fr.wordpress.org/team.

Cet article est en partie issue d’une traduction de cet article sur WordPress.org (en anglais).

Laisser un commentaire

This site uses Akismet to reduce spam. Learn how your comment data is processed.