Classic Editor

Description

Classic Editor est une extension officielle maintenue par l’équipe de WordPress, qui remet en place le précédent éditeur de WordPress et son écran de rédaction. Il permet d’utiliser les extension qui visent cet écran, qui ajoutent des blocs méta, ou de manière générale visent l’éditeur précédent.

Classic Editor est une extension officielle de WordPress, et sera totalement prise en charge et maintenue jusqu’à au moins 2022, ou aussi longtemps que cela est nécessaire.

Pour résumer, cette extension ajoute ce qui suit :

  • Les administrateurs peuvent sélectionner l’éditeur par défaut pour toutes les utilisatrices et tous les utilisateurs.
  • Les administrateurs peuvent autoriser les utilisatrices et utilisateurs à changer leur éditeur par défaut.
  • Il est possible de permettre aux utilisatrices et utilisateurs de choisir l’éditeur a utiliser pour chaque publication.
  • Chaque publication s’ouvre avec le dernier éditeur utilisé (classique ou par bloc), quelle que soit la personne qui l’a modifié en dernier. C’est important, car cela permet de maintenir une expérience de rédaction cohérente.

Par ailleurs, l’extension Classic Editor comprend plusieurs filtres qui permettent à d’autres extensions de contrôler ses réglages, ainsi que le choix de l’éditeur par publication et par type de publication.

Par défaut, cette extension masque toutes les fonctionnalités proposées par le nouvel éditeur par blocs (Gutenberg).

Captures d’écran

  • Réglages de l’administrateur sur l’écran Réglages -> Écriture.
  • Réglages d’utilisateur sur l’écran de son Profil. Visible uniquement quand les utilisatrices et utilisateurs sont autorisé-e-s à changer d’éditeur.
  • « Liens d'action » pour choisir un autre éditeur. Visible uniquement quand les utilisatrices et utilisateurs sont autorisé-e-s à changer d’éditeur.
  • Lien pour basculer de l’éditeur par blocs au Classic Editor lors de la rédaction d’une publication. Visible uniquement quand les utilisatrices et utilisateurs sont autorisé·e·s à changer d’éditeur.
  • Lien pour basculer de Classic Editor à l’éditeur par blocs (Gutenberg) lors de la rédaction d’une publication. Visible uniquement quand les utilisatrices et utilisateurs sont autorisé·e·s à changer d’éditeur.
  • Réglages réseau pour sélectionner l’éditeur par défaut du réseau et autoriser les admins du site de le modifier.
  • Le lien « Basculer à l’éditeur classique ».

FAQ

Réglages par défaut

Lorsqu’il est activé, cette extension restaure l’éditeur WordPress précédent (« classique ») et masque le nouvel éditeur de blocs (« Gutenberg »).
Ces réglages peuvent être modifiés dans Paramètre => Écran.

Réglages par défaut pour l’installation du réseau

Il y a deux options :

  • Lorsqu’il est activé par le réseau, cette extension définit l’Éditeur Classique par défaut et empêche les administrateurs du site et les utilisateurs de changer d’éditeur.
    Les réglages peuvent être modifiés et l’éditeur par défaut pour l’ensemble du réseau peut être sélectionné dans les Réglages Réseau.
  • Lorsqu’il n’est pas activé par le réseau, chaque administrateur de site pourra activer l’extension et choisir des options pour ses utilisateurs.

Il se trouve dans le menu principal de l’Éditeur de Blocs, voir ceci capture d’écran.

Avis

11 avril 2022
The Classic editor was working fine, but in the last days it isn't showing the visual option, which makes it hard for writers to edit the text and add images, and so on. I was hoping to find a way that the writers of the content don't had the need to acces the elementor editor and unintentionally break the design.
4 avril 2022
I love the block editor, but...sometimes I get that aggravatingly vague error ("The editor has encountered an unexpected error") when I try to open older posts in Gutenberg. No matter what I try, I can't get the error to go away. So I'm very grateful that we still have access to a pre-Gutenberg version of the editor, just so I can get around that error and get my work done. Thank you!
29 mars 2022
Gutenberg also have code editor mode. No need for this plugin anymore.
Lire les 1 062 avis

Contributeurs & développeurs

« Classic Editor » est un logiciel libre. Les personnes suivantes ont contribué à cette extension.

Contributeurs

“Classic Editor” a été traduit dans 68 locales. Remerciez l’équipe de traduction pour ses contributions.

Traduisez « Classic Editor » dans votre langue.

Le développement vous intéresse ?

Parcourir le code, consulter le SVN dépôt, ou s’inscrire au journal de développement par RSS.

Journal

1.6.2

  • Fixed bug that was preventing saving of the last used editor.

1.6.1

  • Fixed a warning on the block editor based widgets screen.
  • Fixed use of a deprecated filter.

1.6

  • Mis à jour pour WordPress 5.5.
  • Correction de problèmes mineurs avec l’appel de fonctions obsolètes, l’enregistrement inutile du crochet de désinstallation et la mise en majuscule de certaines chaînes.

1.5

  • Mise à jour pour WordPress 5.2 et Gutenberg 5.3.
  • Amélioration et correction de la logique des « messages ouverts dans le dernier éditeur utilisé pour les modifier ».
  • Correction de l’ajout de l’état de la publication pour qu’elle soit facilement accessible depuis d’autres extensions.

1.4

  • Sur les installations réseau, la restriction relative à l’activation du réseau a été supprimée.
  • Ajout de la prise en charge des administrateurs réseau pour choisir l’éditeur par défaut pour l’ensemble du réseau.
  • Correction du lien de paramétrage dans l’avertissement sur l’écran. À propos du réseau.
  • Ajout de l’option de menu « Basculer à l’Éditeur Classique » dans le menu de l’Éditeur de Blocs.

1.3

  • Correction de la suppression du widget « Essayez Gutenberg » du tableau de bord.
  • Correction d’une condition pour l’affichage de l’avis d’après mise à niveau sur la page « Quoi de neuf ». Affiché lorsque l’Éditeur Classique est sélectionné et que les utilisateurs ne peuvent pas changer d’éditeur.

1.2

  • Correction sur le changement d’éditeurs à partir de l’écran Ajouter une nouvelle (publication) avant qu’un message brouillon ne soit sauvegardé.
  • Correction d’une faute de frappe qui ajoutait l’URL de modification à la variable de la requête de classic-editor.
  • Changement de la détection de WordPress 5.0 pour ne pas utiliser le contrôle de version. Correctif d’un bogue lors du test de l’alpha 5.1.
  • Modification de la valeur par défaut de l’option pour autoriser les utilisateurs de changer d’éditeur sur faux.
  • Ajout de la désactivation de l’extension Gutenberg et de l’abaissement de la version WordPress nécessaire à 4.9.
  • Ajout du filtre classic_editor_network_default_settings.

1.1

Correctif d’un bogue où il était possible de charger l’Éditeur de Bloc pour les types de publications qui ne prennent pas en charge l’éditeur lorsque les utilisateurs sont autorisés à changer d’éditeur.

1.0

  • Mise à jour pour WordPress 5.0.
  • Changement de tous les noms et références de « Gutenberg » en « Éditeur de Blocs ».
  • Rafraîchir les paramètres de l’interface utilisateur.
  • Suppression de la désactivation de l’extension Gutenberg. Ceci a été ajouté pour être testé dans WordPress 4.9. Les utilisateurs qui veulent continuer à suivre le développement de Gutenberg dans WordPress 5.0 et au-delà n’auront pas besoin d’une autre extension pour le désactiver.
  • Ajout de la prise en charge des réglages de l’éditeur par défaut pour chaque utilisateur.
  • Ajout de la prise en charge des administrateurs pour définir l’éditeur par défaut du site.
  • Ajout de la prise en charge des administrateurs pour permettre aux utilisateurs de changer leur éditeur par défaut.
  • Ajout de la prise en charge des administrateurs réseau pour empêcher les administrateurs du site de modifier les paramètres par défaut.
  • Ajout du support pour stocker le dernier éditeur utilisé pour chaque message et l’ouvrir la prochaine fois. Activé lorsque les utilisateurs peuvent choisir l’éditeur par défaut.
  • Ajout de « l’état de l’éditeur de messages » dans la liste des messages sur l’écran Messages. Affiche l’éditeur qui sera ouvert pour le message. Activé lorsque les utilisateurs peuvent choisir l’éditeur par défaut.
  • Ajout des filtres classic_editor_enabled_editors_for_post et classic_editor_enabled_editors_for_post_type. Peut être utilisé par d’autres extensions pour contrôler ou surcharger l’éditeur utilisé pour type de publication particulier.
  • Ajout du filtre classic_editor_plugin_settings. Peut être utilisé par d’autres extensions pour remplacer les paramètres et désactiver les paramètres de l’interface utilisateur.

0.5

  • Mise à jour pour Gutenberg 4.1 et WordPress 5.0-beta1.
  • Suppression de certaines fonctionnalités qui existent maintenant dans Gutenberg.
  • Correction de la redirection vers l’Éditeur Classique après avoir regardé les révisions des messages.

0.4

  • Correction de la suppression de l’appel « Essayez Gutenberg » lorsque l’extension Gutenberg n’est pas activé.
  • Correction pour toujours afficher les paramètres et le lien des paramètres dans le tableau de la liste des extensions.
  • Mise à jour du texte du fichier readme.

0.3

  • Mise à jour de l’option d’une case à cocher vers un couple de boutons radio, cela apporte plus de clarté. Merci à @designsimply pour les suggestions de texte des étiquettes.
  • Quelques mises à jour générales et nettoyage.

0.2

  • Mis à jour pour Gutenberg 1.9.
  • Supprime l’avertissement et la désactivation automatique lorsque Gutenberg n’est pas actif.

0.1

Sortie initiale.