Juiz Outdated Post Message

Description

This plugin adds a message before or after (or both) your post content when this post is outdated.
You visitor knows when a post is a little bit outdated and reads the content keeping its age in mind.

Fonctionnalités

  • Choose the place where the message is displayed (before or after the content, or both)
  • Choose which type of posts that are concerned
  • Custom delay for each post
  • Hide the message for a specific post (directly from the edition page)
  • Shortcode and template function
  • Lots of hooks (for developers)

A full documentation is coming.

If you find a bug, please, tell me!

You want to translate this plugin and have your name in this page? Find translation files here.

Captures d’écran

  • The options page
  • The metabox in a post edition (specific options)
  • The message displayed before the content

Installation

You can use one of both method :

Installation via your WordPress website

  1. Go to the admin menu ‘Plugins’ -> ‘Install’ and search for ‘Juiz Outdated’
  2. Click ‘install’ and activate it
  3. (optional) Configure the Plugin in Appearance

Manual Installation

  1. Download the plugin (it’s better :p)
  2. Unzip juiz-outdated-post-message folder to the /wp-content/plugins/ directory
  3. Activate the plugin through the ‘Plugins’ menu in WordPress
  4. It’s finished !

FAQ

No question for the moment

Avis

6 février 2017
Works like a charm! If you want to use the shortcode in your template, do it like this : <?php echo do_shortcode('[outdated]'); ?>
Lire les 5 avis

Contributeurs & développeurs

« Juiz Outdated Post Message » est un logiciel libre. Les personnes suivantes ont contribué à cette extension.

Contributeurs

“Juiz Outdated Post Message” a été traduit dans 1 locale. Remerciez l’équipe de traduction pour ses contributions.

Traduisez « Juiz Outdated Post Message » dans votre langue.

Le développement vous intéresse ?

Parcourir le code, consulter le SVN dépôt, ou s’inscrire au journal de développement par RSS.

Journal

1.0.4

  • Bug fix / Compatibility
    • Compatible with PHP8.
    • Tested on the latest WordPress version

1.0.3

  • Compatibility:
    • Tested up to WordPress 4.5 (RC1)
    • Tested up to PHP7
  • Engine:
    • Better code readability
    • Some improvements in security (with translations)
    • Information message bug fixed in settings page

1.0.2

  • Tested in WordPress 4.4.1
  • Interface:
    • Admin icon post type displayed in settings page
  • Improvements:
    • PHP Notice removed
    • Code error with shortcode fixed (do_shortcode('[outdated]') should works better)
    • Code design improvement

1.0.1

  • Notice in PHP 5.4 fixed

1.0.0

  • The first stable version, tell me if you find something wrong.