Mettez à jour votre version de PHP

En mettant à jour votre version de PHP, votre site WordPress sera plus rapide et plus sécurisé !

Cette page explique en quoi cela est important pour votre site, et comment vous y prendre pour effectuer ces mises à jour spécifiques.

Pourquoi la version de PHP utilisée par votre site est-elle importante ? Pourquoi la version de PHP utilisée par votre site est-elle importante ?

PHP est le langage de programmation principal sur lequel WordPress est bâti. La version de PHP sur laquelle votre site tourne est gérée au niveau du serveur par l’entreprise qui héberge votre site. Si vous êtes déjà sans doute sensibilisé·e à l’importance de bien mettre à jour WordPress, vos thèmes et vos extensions, sachez que mettre à jour votre version de PHP est tout aussi important.

Voici les deux principaux avantages à garder votre version de PHP à jour de version :

  • Votre site sera plus rapide puisque les nouvelles versions de PHP sont toujours plus performantes que les précédentes. Une mise à jour vers la dernière version de PHP prise en charge peut fournir une énorme amélioration des performances de votre site. Par exemple, certaines versions de PHP sont jusqu’à 3 ou 4 fois plus rapide que la version qui les ont précédées.
  • Votre site sera plus sécurisé. Tout comme WordPress, PHP est maintenu par sa communauté. Comme PHP est un language de programmation très populaire, il est lui aussi ciblé par des actions de piratage – mais la dernière version du langage est maintenue et reçoit constamment des correctifs de sécurité. Les versions trop anciennes de PHP ne sont plus maintenues, il est donc essentiel de garder votre site WordPress sécurisé en mettant régulièrement à jour la version de PHP de votre serveur.

Et il y a aussi un grand nombre d’avantages secondaires :

  • Un site WordPress plus rapide sera apprécié par les moteurs de recherche, ce qui vous aidera à mieux vous positionner dans les résultats de recherche !
  • Un site WordPress plus rapide retiendra mieux l’attention des personnes visitant votre site (et elles partiront si celui-ci prend trop de temps à charger), ce qui rendra votre site plus efficace.
  • Un site WordPress plus sécurisé et mieux protégé des pirates, et il ne faut pas sous-estimer l’impact négatif d’un piratage sur votre réputation et sur votre activité.

Ces avantages sont bons pour votre site, et bons pour les personnes qui vont le visiter. Ce sont les raisons pour lesquelles vous devriez mettre à jour votre version de PHP aujourd’hui. La section suivante vous expliquera comment faire.

Haut ↑

Avant de mettre à jour votre version de PHP Avant de mettre à jour votre version de PHP

Cette section commence par quelques avertissements, mais n’ayez pas peur ! Comme pour toute intervention technique, mieux vaut passer en revue quelques pré-requis avant de passer aux choses sérieuses 🙂

La mise à jour de la version de PHP utilisée par votre site ne devrait pas poser de problème, mais il est impossible de garantir à 100 % qu’il n’y aura pas d’imprévus. Cela étant dit, il y a bien plus de risque à ne pas mettre à jour votre version de PHP. WordPress ne prend en charge que les versions de PHP supérieures ou égales à 5.6 et recommande plutôt 7.4 ou plus récent. Par ailleurs, la plupart des extensions et thèmes populaires nécessitent l’utilisation d’une version moderne de PHP.

Voici quelques conseils à mettre en œuvre avant la mise à jour afin de limiter les risques :

  1. Sauvegardez votre site : une sauvegarde vous permettra de remettre votre site tel qu’il était avant si quoique ce soit ne se passe pas comme prévu. Lisez notre article sur la sauvegarde. Si vous avez besoin de restaurer votre sauvegarde, vous devrez remettre la version de PHP précédente.
  2. Mettez à jour WordPress, vos thèmes et vos extensions : vous pouvez le faire à partir de votre Tableau de bord, comme expliqué dans cet article sur la mise à jour de votre site WordPress. N’oubliez cependant pas que cela doit de toute façon être fait très régulièrement 🙂
  3. Vérifiez la compatibilité de votre site avec la version de PHP que vous souhaitez utiliser : pour cela, installez l’extension PHP Compatibility Checker pour scanner vos extensions et thèmes à la recherche de risques d’incompatibilités potentielles. Cette extension n’est pas parfaite et peut louper des éléments ou remonter des faux positifs, mais elle fonctionne bien pour la plupart des cas.
  4. Corrigez tout problème potentiel de compatibilité PHP : si l’extension décrite ci-dessus remonte la moindre erreur, contactez directement les personnes développant l’extension ou le thème concerné via leur support. Si personne ne vous répond, parcourez le répertoire des thèmes et extensions sur WordPress.org à la recherche de ressources proposant les mêmes fonctionnalités et remplacez-les.

Une fois ces étapes effectuées, nous pourrons nous lancer dans la mise à jour de la version de PHP utilisée par votre site !

Si vous rencontrez des problèmes qui dépassent vraiment votre compréhension, n’hésitez à ouvrir un sujet sur le forum de l’association WPFR, les personnes contribuant bénévolement à ce forum d’entraide vous aideront autant que possible. Vous pouvez aussi vous inscrire sur le Slack WordPress FR pour discuter de vos soucis avec d’autres usagers de WordPress.

Haut ↑

Comment mettre à jour la version de PHP de votre site Comment mettre à jour la version de PHP de votre site

Nous sommes maintenant fin prêts à mettre à jour votre site ! Vous avez pris connaissance des informations ci-dessus, vous avez fait une sauvegarde, vous avez vérifié la compatibilité de votre thème et de vos extensions, tout devrait bien se passer.

Pour commencer, dans la mesure ou la version de PHP est gérée au niveau serveur par votre hébergeur, la mise à jour va nécessiter soit de modifier les réglages de votre hébergement, soit de demander à votre hébergeur de le faire.

Pour ainsi dire, la procédure exacte de la mise à jour de PHP dépend fortement de votre hébergeur. Nous avons demandé aux plus grandes entreprises d’hébergement de nous fournir leurs instructions spécifiques et vous pourrez les trouver sur un fichier GitHub disponible à cette adresse (en anglais).


Si vous ne trouvez pas votre hébergeur sur cette liste, nous vous conseillons d’envoyer l’e-mail suivant à votre hébergeur (ou de copier-coller cela sur leur outil de tickets) :

Cher hébergeur,

Je souhaiterais rendre mon site aussi performant et sécurisé que possible en utilisant une version plus récente de PHP. Pour mon site tournant sur WordPress, la version minimale recommandée est PHP 7.4. J’aimerais m’assurer que c’est bien la version utilisée sur mon site, et si ce n’est pas le cas, que vous m’indiquiez les étapes permettant de mettre à jour la version de PHP utilisée sur mon hébergement.

Merci d’avance

Une fois votre version de PHP mise à jour, vérifiez que votre site fonctionne correctement. Si vous rencontrez le moindre problème, remettez (ou faites remettre) la version de PHP précédemment utilisée et tentez d’identifier le problème ou de rejoindre le forum WPFR ou le Slack WordPress FR.

Souvenez-vous : en mettant à jour votre version de PHP, vous contribuez à rendre internet plus performant et plus sécurisé, ce qui profite à tout le monde 🌟

Traduit par Jb Audras
Relu par Sébastien SERRE & Jenny Dupuy
Dernière mise à jour le 06 octobre 2021

Contribuer à la documentation en français de WordPress